mirror of
https://github.com/JulienMalka/snowfield.git
synced 2025-03-23 20:30:52 +01:00
14 lines
344 B
Nix
14 lines
344 B
Nix
{ config, ... }:
|
|
{
|
|
networking.useNetworkd = true;
|
|
systemd.network.enable = true;
|
|
systemd.network.networks."10-wan" = {
|
|
matchConfig.Name = config.machine.meta.defaultInterface;
|
|
networkConfig = {
|
|
DHCP = "ipv4";
|
|
Address = config.machine.meta.ips.public.ipv6;
|
|
};
|
|
linkConfig.RequiredForOnline = "routable";
|
|
};
|
|
|
|
}
|