mirror of
https://github.com/JulienMalka/snowfield.git
synced 2025-03-25 21:30:52 +01:00
22 lines
459 B
Nix
22 lines
459 B
Nix
{ config, inputs, ... }:
|
|
let
|
|
inherit (import inputs.unstable { }) readeck;
|
|
in
|
|
{
|
|
|
|
age.secrets."readeck-config".file = ../../secrets/readeck-config.age;
|
|
|
|
services.nginx.virtualHosts."read.luj" = {
|
|
forceSSL = true;
|
|
enableACME = true;
|
|
locations."/" = {
|
|
proxyPass = "http://localhost:8000";
|
|
};
|
|
};
|
|
|
|
services.readeck = {
|
|
enable = true;
|
|
package = readeck;
|
|
environmentFile = config.age.secrets."readeck-config".path;
|
|
};
|
|
}
|