mirror of
https://github.com/JulienMalka/snowfield.git
synced 2025-03-25 21:30:52 +01:00
32 lines
539 B
Nix
32 lines
539 B
Nix
{
|
|
config,
|
|
pkgs,
|
|
lib,
|
|
...
|
|
}:
|
|
let
|
|
cfg = config.luj.programs.gtk;
|
|
in
|
|
with lib;
|
|
{
|
|
options.luj.programs.gtk = {
|
|
enable = mkEnableOption "Enable gtk customizations";
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
gtk = {
|
|
enable = true;
|
|
theme = {
|
|
name = "Catppuccin-Macchiato-Standard-Pink-Dark";
|
|
package = pkgs.catppuccin-gtk.override {
|
|
accents = [ "pink" ];
|
|
variant = "macchiato";
|
|
};
|
|
};
|
|
};
|
|
qt = {
|
|
enable = true;
|
|
platformTheme.name = "gtk";
|
|
};
|
|
};
|
|
}
|