mirror of
https://github.com/JulienMalka/snowfield.git
synced 2025-03-25 21:30:52 +01:00
23 lines
299 B
Nix
23 lines
299 B
Nix
{
|
|
config,
|
|
pkgs,
|
|
lib,
|
|
...
|
|
}:
|
|
let
|
|
cfg = config.luj.programs.firefox;
|
|
in
|
|
with lib;
|
|
{
|
|
options.luj.programs.firefox = {
|
|
enable = mkEnableOption "Enable Firefox";
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
programs.firefox = {
|
|
enable = true;
|
|
package = pkgs.firefox;
|
|
};
|
|
|
|
};
|
|
}
|