mirror of
https://github.com/JulienMalka/snowfield.git
synced 2025-03-25 21:30:52 +01:00
16 lines
231 B
Nix
16 lines
231 B
Nix
{ config, lib, ... }:
|
|
let
|
|
cfg = config.luj.programs.emacs;
|
|
in
|
|
with lib;
|
|
{
|
|
options.luj.programs.emacs = {
|
|
enable = mkEnableOption "Enable Emacs";
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
|
|
services.emacs.enable = true;
|
|
|
|
};
|
|
}
|